Testing Dagon for Unity


#61

Yeah, I caved… sort of. Compare the face of Bastion (I’ll bet that Alina said “no” to naming him “Cthulhu”) frowning with Agustin frowning while holding him. Can you say, “cloned?” :stuck_out_tongue:


#62

What do you think about Unity 5 compatibility Agustin? Looks like free version of Unity 5 doesn’t have any feature limitations. Are you planning to use it?


#63

Yeah, you can’t imagine how happy I am that they’re opening all features after we committed to yearly subscriptions :stuck_out_tongue:

But yes, I’m actually doing some tests right now and I’ll report back with news.


#64

Hi. I followed the first 4 steps, plus commenting out the LoadVideo suggestion.
I still get an error and nothing is loading, no scripts, no Dagon Inspector…

Assets/Dagon/Scripts/Views/BlendScene.cs(41,20): warning CS0649: Field BlendScene.inventoryController' is never assigned to, and will always have its default valuenull’


#65

I don’t know what that is, Shadowphile, and I don’t think that I’ve gotten that message before. I realize this is a cs file ultimately causing the error, but sometimes if I just reimport all of the lua files individually and then reboot Unity a couple of times, it seems to work itself out.


#66

Wait, that warning shouldn’t cause you any troubles. Did you download the DagonitySample? It’s no longer available, so let me know if I should re-upload it :slight_smile:


#67

yes, I exactly followed the first four steps from Imari’s post.
I know it is partially seeing the DagonitySample because I can find some of the assets like the sky textures. But every script I looked at in the inspector say’s something like ‘not found’.
I can understand why BlendScene.inventoryController should not prevent the other stuff, but right now I’m clueless about the entire structure. Is this a clue to a bigger problem?


#68

Can you post a screen capture of the inspector and hierarchy of gameobjects? That will allow me to quickly assess the issue. More than likely something is missing, or you must reconfigure some aspect of Unity (certain settings are lost in translation when pushing to GitHub).


#69

I’m happy to report that Dagon is working very well with Unity 5.0, including some noticeable performance improvements :slight_smile:

I will be committing updates soon!


#70

I can’t find how to directly insert an image. There are two files attached:
-A snapshot of Unity with errors and stuff.
-A screenshot of my folder layout. Can’t show files but you can see if maybe my folder layout is wrong.
thanks



#71

Wait, there’s something awfully wrong here. It’s like it’s trying to load all the scripts twice.

Try removing the zip file from the folder structure. Maybe Unity thinks that’s another plugin.


#72

that didn’t help.
Is there a full log file somewhere?


#73

The log file is the console window. Strange thing is that the first error is related to the iTween plugin (not ours) being loaded twice, which is why I think there’s something wrong on your organization of folders.

To be sure, extract the DagonitySample file again and copy the contents of dagon-unity-master inside the Dagon folder of the DagonitySample folder. It should run without issues…


#74

Agustin, I tried Dagonity with Unity 5 but I’m getting this error (when I choose Game Controller) :

NullReferenceException: Object reference not set to an instance of an object Dagon.GameController.GetCurrentLocationName () (at Assets/Dagon/Scripts/Controllers/GameController.cs:212) GameControllerView.OnInspectorGUI () (at Assets/Dagon/Scripts/Views/Editor/GameControllerView.cs:35) UnityEditor.InspectorWindow.DrawEditor (UnityEditor.Editor editor, Int32 editorIndex, Boolean forceDirty, System.Boolean& showImportedObjectBarNext, UnityEngine.Rect& importedObjectBarRect, Boolean eyeDropperDirty) (at C:/buildslave/unity/build/Editor/Mono/Inspector/InspectorWindow.cs:1150) UnityEditor.DockArea:OnGUI()

and this too when I try to run the game:

NullReferenceException: Object reference not set to an instance of an object Dagon.Game.RunScript (System.String script) (at Assets/Dagon/Scripts/Models/Game.cs:287) System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

I downloaded the latest build of Dagonity too. Did I do something wrong while importing the assets I wonder? It did give some “These are old” warnings and I clicked on “Upgrade/Update” options. Could it be I need a newer Dagonity Sample? I have the first one you shared.


#75

Hhhmmm, I did push the migration of Dagonity to GitHub. Did you actually download the whole zip again? I guess I should test if the repo is fully up-to-date, but our local copy of Asylum is working just fine with Unity 5.


#76

Yes I downloaded dagon-unity using “Download Zip” option on the right. I tried a few different things like using the sample files that were compiled with Unity 4 and upgrading those to 5 or using DagonitySample directly with Unity 5, but while error messages changed it never worked. Assets are there, but scripts are not working.


#77

Oh OK, I see the issue now. I did not update Dagonity sample for the Unity 5 code, so it’s understandably going to throw a few errors.

Please, give me a few days and I’ll upload a proper package for testing. I’m getting to the point where we can start distributing Dagonity as a “proper” Unity package :slight_smile:


#78

Good to hear, Agustin! Thanks.


#79

Good to hear, Agustin. :slight_smile:


#80

Hey Cleo! Have you seen the latest KS update? There are brand new sightings of Bastian :smiley: