Slides and FOV


#1

I did my first slide last night and stumbled upon some issues regarding scaling…and didn’t really find an answer here or in the wiki.

The problem was - whatever scale or proportions I had, I could not get the slide/bg to fill my screen. I tested to change various stuff in the config (res and fullscreen params)…but with no luck. I kind of figured out some of it, by testing my gfx in a untouched teaser…and since Agustín uses his ‘claustrofobic’ FOV…it worked (Asylum 55 degr, my testproj 78 degr). So is there someone that could explain/elaborate on how the slides are actually set up? I mean, it would be a quad with a texture…right? But does that mean the engine, for now, is ‘hardcoded’ to work with Asylums specific FOV? Or am I able to set some parameters on the slide to fit my FOV? (right now my solution is a hack - switch FOV to ~55 when entering a slide, and switching it back when returning…which kind of make the nice transition glitch a bit cause you see the switch…)

Skickat från min GT-I9100 via Tapatalk 2


#2

I’m not sure if I can answer your question, but some elements of Dagon assume that you are using a cube size with 2048 x 2048 faces. I’ve tried adjusting the FOV in game, but not when using slides.

Just FYI, I’m using Vue, in which a camera set at 18mm is equal to 90 FOV. To render a slide, I just change my render size from 2048 x 2048 to 1920 x 1200, without moving the camera or changing the aperture and thus far, it’s worked fine. I was using CPage and SCream prior to Dagon, so I was familiar with that shock of finding your nose to the wall when actually viewing the nodes in “game.” So now, to avoid things looking too claustrophobic, I arrange my scenes’ models to be more spread out than would be “real.”


#3

It is a quad indeed, but it’s currently rendered to match the breathing effect in Asylum, so there’s some degree of hardcode at the time being.

However, your slide will fill the screen if you disable the effect (ie: camera.breathing = false). Let me know if that does the trick, it should work!


#4

Hi guys…and thanx for the responses!

@Agustín: I tried to set the camera.breathe = false…but the problem still persists.

To check what I mean;

  • Set camera.fov = 78 (before you start or in the console I guess does not matter)
  • Go to (or switch to) the Infirmary
  • Click on the board, to see the closeup/slide

Now you´ll have black borders all around the image…or is it just me?!

/Tobias


#5

OK, I’ll check this out. As far as I recall, the slide was stretched to fill the screen if the breathing effect is disabled. That’s the expected behavior.


#6

Ok. Maybe it’s me missing something then… But is there anything in the resolution or proportions of the image that can f**k things up? Just good to know if so I mean…

Skickat från min GT-I9100 via Tapatalk 2


#7

OK, there’s definitely a problem and the FOV is indeed affecting the slides. This is incorrect.

A workaround would be to define custom functions that set the default FOV, switch to the slide, then return to your desired FOV. It sucks and I suggest you don’t do it – this should be fixed soon!


#8

Ok. Thanx man. The solution you mention is exactly what I do at the moment…but I am only doing an early test…so no panic here August! Thanx for the effort anyway.

Skickat från min GT-I9100 via TapanywAy!atalk 2