fadeIn/fadeOut

Agustin, are fadeOut and fadeIn only for overlays or can they and setFadeSpeed(speed) be used with nodes and slides?

Thanks.

Every object in Dagon can be faded out/in, including audios. That’s right, you can set the fade speed for audio objects as well.

You can try fading nodes (it’s done in the teaser, even). Typically, you will fade overlays or slides. Let me know if all works as expected!

Thanks for the answer, Agustin. :slight_smile:

I wanted to try fading patches in and out in lieu of dragging. When I’ve got something working, I’ll let you know how it works.

Eh… I’m not quite sure if it will work with patches yet. It should. If it doesn’t, we’ll fix it :nod:

Sent from my iPhone using Tapatalk

Ah, yes. It was patches that I was trying and it did not seem to work. I figured it was something that I was doing wrong. :stuck_out_tongue:

Speaking of patches…
I have a patch on top of a patch that displays and the cursor for it changes as it is supposed to. The patch itself, however, is stretched and the image is split up as though it’s being read wrong. I’ve checked the coordinates for the patch, have remade the PNG file in case it was corrupted, and even changed it out for a jpg file in case it was a cache issue. Nothing has solved this yet. Have you ever experienced this?

Hhmmm… No. What happens if you draw both patches separated from each other? Also, where is this happening? Top/down or the common cardinal directions?

Both are on a side face of the cube (SOUTH). When separated both display. This may be a hardware issue, because I was able to get both to display, but RF2 was not. :frowning:

They’re overlapping, yes. I’ll make a note to minimally separate patches, which should do the trick :nod:

Sent from my iPhone using Tapatalk

The overlapped patches worked for me as is, but not for RF2. We’re still testing to try and figure out what the problems is.

[Just FYI, RF2 had another (and possibly unrelated) crash when trying to enter a particular node, which ran fine on my computer. The fault referenced was ig4ic32.dll, which appears to involve the video card. She has an i7 on a Lenox and Lenox apparently uses it’s own drivers.]

Regarding the crash, it’s definitely unrelated and every now and then I also experience one. It will be eventually fixed :wink:

Agustin, here is an example of the PNG file for a patch as it should display and an image cut from a screenshot showing the distortion we’re getting.

This is happening randomly (and often! :frowning: ) with spots. Sometimes they appear fine on my computer, but not on RF2’s and sometimes they are distorted on both computers. We’ve both checked to make sure drivers are up to date and that the coordinates are correct for the patch. Is this what the “fix” that you mentioned should correct?

Hhhmmmm, yes, this has happened before. Now that I’m seeing the captures, it’s not what I originally thought.

Try using a different size for the textured. It is a driver problem, but easily solvable. It’s related to incompatible size of textures (the power of 2 thing).

Just make sure both x and y coordinates are even first. If that doesn’t work, try ensuring they’re both power of 2. That will do the trick :nod:

Sent from my iPhone using Tapatalk

Aha… glad it’s an easy solution. I’ll try it and if it doesn’t work, will report back. Thanks! :slight_smile:

Update: Okay, now that patch works. But Agustin, way over half of my patches have at least one uneven number of pixels on a side. These all have worked fine thus far. Do I need to go back and crop and reposition these as well?

No, don’t bother if they work. However, I would advise to perform an in-depth beta test when the time comes. In a way, you will be benefited by our own testing with Asylum since we’re going to keep an eye on incompatibilities such as this :slight_smile:

Sent from my iPhone using Tapatalk

Okay, so now I’m a test dummy… :stuck_out_tongue: