Dagon 1.0.0 (alpha 1012) - The Your-Wishes-Came-True Build

The Asylum teaser is nearly complete. We practically addressed EVERYTHING you mentioned, and I mean that. Skipping dialogues, direct control, WASD keys, close-ups, and of course a plethora of fixes. Josh redid all the lines as well and he sounds much more in character this time. We’re thrilled with the results and I hope you are too.

There are a few rough edges yet: we want to improve some more graphics (especially the corkboard in the Infirmary) and the readings in the map are outdated (ie: you can still see “Hospital”). Also, the end of the teaser is very abrupt; we’re going to add a final screen when it’s all done.

Please, it’s very important that you give us feedback as soon as possible if you find critical bugs. There shouldn’t be any, but you never know. We expect to have the FINAL version on Monday, Tuesday tops. Next Friday we’re travelling to the Gamescom event, where the teaser will be launched, so we’d really appreciate your efforts. The idea is to test these major changes this weekend and then one more test next week.

Expert users: please, do try all the new configuration modes. They are listed in Dagon.cfg. You’ll also see some of the new settings as well such as disabling subtitles, or silent feeds (like in Scratches).

Again: THANK YOU!


You can review everything that’s been fixed and pending things here: viewtopic.php?f=3&t=1193


Links

[ul][li] Windows: https://www.dropbox.com/s/qcesehkro0mcr … er_Win.zip[/li]
[li] Windows XP Fix: https://www.dropbox.com/s/8dxxxkfciqnsg … 12_Fix.zip[/li]
[li] Mac: https://www.dropbox.com/s/a26o61n0sydhm … er_Mac.zip[/li]
[li] Linux: Coming Soon[/li][/ul]

Note the Mac build includes the teaser this time, so you don’t need to download the Windows one.


Developers: The code is quite messy now. I’ll also take the opportunity to cleanup everything this weekend.

Nice work :slight_smile:
I just gave it a quick go, and with the default settings it does seem a lot better, although the turn was slow, but it is a 2 core 32bit system, I like the close ups and the right click has improved things.
I’ll give it a good going over in the morning :wink:
I’ll check out the cfg file now coz I think its change plan B in my latest efforts :stuck_out_tongue:

OK, great!

Forgot to mention: the Slides code is live. Basically, they behave like a simplified node. I did this to support a 3D project and maintain the breathing effect. It’s a bit patchy but it works. It will be improved in later builds.

As you can see, a slide is created with one line, and that’s pretty much ALL you need for simple closeups. The engine defines the “return” hotspot for you even. They support audios, videos, and the whole shebang. The only difference is that spots don’t need to have the cube face specified (if you use anything other than NORTH, they won’t show up).

Afraid mine didn’t even start. Just froze, nothing but a blank, unresponsive screen.
[Aug 3 20:02:47] SYSTEM -> ========================================
[Aug 3 20:02:47] SYSTEM -> Initializing system…

So it looks like it just caught itself in some kind of loop on startup.

Was the previous version working flawlessly for you? What if you set Fullscreen to false?

Sent from my iPhone using Tapatalk

The previous version started up just fine…and setting fullscreen = false doesn’t change anything.

I’ve reviewed the code and nothing has changed during that sequence. You sure it’s nothing else?

Try debugMode = true, just in case. That’s something different this time.

Sent from my iPhone using Tapatalk

Nope, I can confirm 100% that between the “Initializing system” log line and the next one (which prints the Dagon version) literally NOTHING has changed, so this baffles me…

No change when I set debugmode to true.

James, please try this new executable which has extended log messages. I have to know where it’s failing exactly… But it’s very strange because the only action performed during that time is creating the actual window:

[url=https://www.dropbox.com/s/8sbui4wexlh81vz/Dagon_Win_1.0.0a1012_Log.zip]https://www.dropbox.com/s/8sbui4wexlh81 ... 12_Log.zip[/url]

Are you positive that nothing has changed in your system since last time? No video drivers updated?

OK, it’s breaking on Windows XP. Just tried with a virtual machine… I’m going to recompile there…

Agustin everything looks gorgeous and very polished. The sound track, the texture and mood of the visuals, and the voiceovers are perfect. People should be blown away.

I went through the demo a couple dozen times, changing the configuration file, rapidly clicking both to move rapidly from node to node and on hotspots and I was not able to break anything. I did not see any seams or other problems, while in full screen and in “free” cursor mode. Also, I had no audio problems whatsoever. I’m on a 32bit Windows 7 machine.

In “free” mode, the movement is very smooth, though perhaps a gauge that the player can use to slow down the spin might be a good thing for some people. For myself, it mostly seemed to take a bit of practice and then I was good.

I did find a few problems with movement, though. -

  • When in windowed mode, trying to turn was sometimes awkward because the cursor is not “trapped” within the window. So, if you drag the mouse beyond the boundaries of the window while turning, you see the windows arrow and movement in the game window stops.
  • In full screen mode, I tried “free”, “fixed”, and “drag” modes, but only the “free” mode worked properly. The “fixed” mode was so jittery as to be unusable and I could not get the camera to turn when in “drag” mode, forward was the only possible direction.

I’m not sure which options will be left up to the player, but should anyone choose to play both without subtitles and without commentary, then the “look” cursor maybe should be disabled — except when there is actually a close-up to be viewed.

Oddly enough, on one run-through, the Windows toolbar appeared at the bottom of my screen while in full screen mode. I could not reproduce the effect and other than the fact that I had several windows open in the background, I have no possible explanation as to why it happened. The windows that were open were just pages in Notepad++ and in Windows Explorer and they were open throughout the testing.

Finally, I’m so glad that you added some “compassionate” comments about the patients. Remember how upset some people (including me!) were at the end of Scratches when the protagonist just drove away? (FYI, my son just shakes his head at me when I say stuff like this and mumbles about me having no clue when it comes to survival horror games. :stuck_out_tongue: )

Oh, and the teddy bear… is that a nod to Scratches? Will he make a cameo appearance in all of your games? You should name him Hitchcock. :smiley:

Thanks Cleo for the thorough comments!! Yeah, fiddling with the Dagon.cfg is going to be for expert users only, and I’ll include a warning that it’s prone to errors (for the time being). The different controls work best during fullscreen, not so much in windowed mode.

Specifically about the Drag mode: did you try holding your left mouse button for a brief moment? It expects that before you begin rotating.

The teddy bear was a nod to Scratches alright :wink:

James: I SOLVED THE PROBLEM. Posting a new exe in a few moments…

Here’s the Windows XP fix: https://www.dropbox.com/s/8dxxxkfciqnsg … 12_Fix.zip

Thank you thank you thank you!

The only negative comments:
Panning is still way too slow. Is fixed-mouse implemented yet?
Solid red block appears in the center of the screen after entering the first node. I think it’s the hotspot. For some reason it’s showing on the transition for that one node.

Otherwise this is great. Feels so polished.

In fixed mode you can’t move after you look at the map, as the close up appears the cursor jumps to the left, then go back to the world view the cursor is no longer locked to center

I think fixed needs a little damping as it is hard to hit a hotspot ie the bell button

in other modes and in windowed view the cursor isn’t trapped in the game

I used the XP version of the executable that you provided.

So far I haven’t noticed any major problem, just a few weird things:

Certain messages seem to appear randomly…Sometimes they do sometimes they don’t:

  • “I remember how busy this place was …” This one didn’t appear at all the first time I played. It did other times.
  • The first time I played, when I clicked the map, he located the infirmary and said he could have just read the sign over the door. When I did that again in a different session, all he would say was “The asylum is huge”
  • Something else happened only on the first time I played: after entering the infirmary, I went back to corridor B and three messages appeared: “Kirkbride. That’s it …”, “It was believed that this style of architecture…”, “There were plans to modernize the construction”, without me clicking anything… Are they supposed to appear randomly or should they respond to any event? I didn’t see them other times I played :s

Maybe it’s just me doing something wrong…

You didn’t mention if other control modes are supposed to be working…

  • I haven’t been able to look around in Drag mode… I tried to move the mouse in the opposite direction of where I want to look with the button down but it always counted as a click. edit: nevermind, I was doing it wrong
  • I suppose you don’t have the time to implement that, but the mouse movement in Fixed mode needs to be a lot smoother…

I noticed a little problem/annoyance in windowed mode: when you look around, if you accidentally move the mouse a bit too far and hit the border of the window, the pointer goes back to the middle of the screen.

Positive stuff now, the voice acting is definitely much better now, it’s great that you could improve it!

btw that teddy bear looked kinda familiar, not sure why :stuck_out_tongue:

Nuxly I found the Drag worked if you click and hold and drag from the center, if you want to turn really quick put the cursor at the other side of the direction you want to go, then click/hold n drag in the right direction likewise you can do it more controlled shortening the drag

I tried it at a lower windowed res and the game runs very sweet on my stone age system

I was thinking, why don’t you trap the player in the Asylum at the end of the teaser and show em rocking back n forth in a cell… or is that just my cruel mind lol

Oooooh ok I understand now! I thought it worked like a drag-and-drop thing.

I tried the drag mode again this morning and it does work, not my favorite mode, but it does work. On my machine, the fixed mode cursor made the screen jitter way too much. It was almost uncontrollable.

Just FYI, Agustin, these are the specs for the machine that I’m testing on. (Maybe you’ll need to know this when figuring out what’s wrong or right when we test?)

Intel Core 2 Quad, 2.40 GHz, 2.39 GHz
4 GB RAM
Windows 7 Professional (SP1), 32bit
NVidia GeForce GTX 550 Ti