Cube maps

I apologize in advance if this question has been asnwered and asked elsewhere. We are a rather niche community and my search attempts have failed me.

Perhaps there is a way to pipe raw images into dagon, but I dont see any documentation (looking forward to shadowphile sharing his findings) on dagon. Sadly dont have time at the moment to crawl through the source, but will soon!

I understand how cube maps work, and how to collect my six images. What I do not understand is how to take thise six images I have made, then turn them into a “.Tex” or anything that I can use in dagon.
I read on the wiki somebody mentioning a tool called ksconvert. But I could not find anything further.

Any tips that anybody could give would be extremly welcome!

Thanks

Certainly content for the wiki. There will be mention in the wiki about the ksconvert tool, where to find it, and how to use non .tex compacted images. All the info is scattered on the forum right now.
I’ll dig up what I can and add edits to this thread. Keep an eye out…

edit: unfortunately the converter tool links are offline tool. Somebody could post a copy they have, me included, but I still find sharing exe files a pain on the web. I don’t like the file-sharing services, always require you to ‘join their world, then find others in the at world’. It’s all about cornering the market.

Anyway, if Agustin manages to provide a new copy of it somewhere or somebody uploads, here some of the forum contributions:
config.tex_compression = false


Agustin: Usage is simple – to create a TEX bundle consisting of six textures, put six images (JPG, TGA or PNG) in the same folder as the executable. Make sure they are named image00001.ext, image00002.ext… image00005.ext

So if image is the node name and ext is the extension, the syntax would be:

ksconvert image tex

ie: ksconvert foyer jpg

In which case you need foyer0000n.jpg files. Hope that makes sense, it’s fairly straightforward!
(me: make sure you use 4 zeroes and n must go from 1 to 6 in the order of N,E,S,W,U,D)

You can always convert files individually if you wish so, stating simply the filename, like this:

ksconvert foyer.jpg

Which will result in foyer.tex

To use non-compacted individual files:…

edit: sorry, I give up. It’s been so long, last time we worked these issues when the engine was still called Kinesis. I got rid of my kinesis experiments a long time ago and frankly it’s probably time for Agustin to put up a new version with clear explanation of how to bring in non .tex cube map files. I do remember this much:
-in config file, set config.compression = false (or something like that)
-in node file, something like newnode = node(N=cubefaceN.png, S=cubefaceS.png, etc) that’s also not exactly correct and could be different by now in the latest versions of Dagon.

another edit: I just looked through the Dagon code. I’m not sure but it looks like it doesn’t even support individual files right now, just the bundled ones. Agustin?

I uploaded the three necessary files, ksconvert.exe, SDL.dll, and MyFiles.bat (by NigeC), as a ZIP file to my site and have linked to them from the wiki page Using Vue d’Esprit to make cubemaps. The link and info on how to use the files is near the bottom of that page.

Agustin, if you want this file deleted from my site and the link removed from the wiki, please let me know. I figured that testers were pretty dead in the water without it.

I made a little utility to make the tex file but can I hell remember were it is :oops:
If I can’t find it I’ll do a better one over the next few days

If it’s your BAT file, Nige, I included it in the ZIP file for download from the wiki. Hoping it’s okay with Agustin until he can put it on his site.

Imari, thanks for that last section on the tex converter, much needed!
It’s too useful for everybody though. I made a dedicated page for it that I linked from ‘all about cubemaps’ Can I suggest you move that paragraph to the dedicated page and just use a link? Don’t want to replicate text because then it becomes hard to update together.

Done, shadowphile. I like how you’ve organized the wiki contents and hope to contribute to it more soon. (The new AC unit is supposed to be installed this week, so perhaps I’ll begin to feel human again. Can’t think with this heat. :-? )

I thinking the convertor I did in this thread:

[url=http://www.senscape.net/forum/viewtopic.php?f=9&t=488]viewtopic.php?f=9&t=488[/url]

BUT revisiting it I can do a lot better now, that one is a bit vague and clunky, watch this space I’ll do a better one over the next week

I’m so used to using your BAT file (which works like a charm :slight_smile: ) that I forgot that you’d worked on a fancier version. Don’t think I have that version, though.

Again, sorry for being MIA these past couple of days!

No problem if Imari hosts the old ksconvert for the time being. In fact, we’re STILL using that tool ourselves. I should get around and re-compile with the Dagon base code, although nothing has changed for the conversion process.

To clarify:

YES, you can load individual files right now. Do this:

config.autopaths = true config.bundleEnabled = false config.texExtension = "jpg" -- or whatever you like
Autopaths is a new feature that looks for resources in a folder tree like the one included in the Asylum teaser. Also, it’s clearer now whether TEX bundles are enabled or not with the next setting.

To completely disable texture compression do:

HOWEVER! The current ksconvert tool will force texture compression on, and potentially introduce artefacts. Keep that in mind.

Awesome, thanks much for clarifying this for me. I can finally get around to building things to explore!

BTW I meant to say autopaths = false before.

Sent from my iPhone using Tapatalk

I still can’t get my non-bundled files to load.
First I stripped the entire teaser down to just a few lines that could load one room with one node, and it loads the one teaser texture I selected just fine.
Then I did as you described in the .cfg file. (using “png”)
Then I changed the node creation to:

node1 = Node("lobby1", "node1s name")

In the Resources/Node folder, same place as the .tex files, I have six individual files:

lobby10001.png, lobby10002.png, etc

These are all 2048x2048 rez pics.
Dagon just spins for a moment without opening up a window then quits.
I also tried autopaths true AND false.
I also tried different lengths of 0’s in the Node code, from none to 3,like “lobby1000”.
sigh. :frowning:

edit: this is weird…
when I use config.autopaths = true or = false, it won’t even load one of the teaser bundles. When I comment it out, then it works…

final edit: got it working!
use ‘config.autopaths’ when inside the code, but just use the ‘autopaths’ on the .cfg file.
Same goes for all the other configs… doh!
BTW, Dagon expects 2 prefixed zeros, ie 001, 002, etc for cube face images. Yay!

Good to know: if Dagon wont’ even start up, look in your .cfg file for something bad.

The autopaths could be a bug, I’ll check it out.

Have you tried “lobby001.png”?