Control issues with game teaser and new version of dagon


I just downloaded the latest version of Dagon and the Teaser (as per the latest Kickstarter update), however the controls seem messed up.

As soon as I press the touch pad the whole screen starts spinning, if I try using the keyboard a similar issue happens.

I am using a Microsoft Surface Pro, with the Type keyboard cover. I’ve detached the keyboard and a similar thing happens - it’s as if the sensitivity of the controls is way too high.

Interestingly if I try the Teaser without the latest version of Dagon the game crashes and fails to load with a “Dagon has stopped working” error message.

So using the latest Dagon I’ve tried playing with the config and enabled the logging (see output below), am I doing something wrong? The “I’m afraid, Dave” message sounds a tad odd!

Thanks in advance!

[Oct 12 20:49:23] CONTROLLER -> ========================================
[Oct 12 20:49:23] CONTROLLER -> Dagon version: 0.6.5a
[Oct 12 20:49:23] CONTROLLER -> Build: 1007
[Oct 12 20:49:23] SCRIPT -> Initializing script…
[Oct 12 20:49:23] SCRIPT -> Lua version: Lua 5.1.5
[Oct 12 20:49:23] SYSTEM -> Initializing system…
[Oct 12 20:49:23] SYSTEM -> SDL version: 2.0
[Oct 12 20:49:23] RENDER -> GLEW version: 1.10.0
[Oct 12 20:49:23] RENDER -> Initializing renderer…
[Oct 12 20:49:23] RENDER -> OpenGL version: 4.0.0 - Build
[Oct 12 20:49:23] AUDIO -> Initializing audio manager…
[Oct 12 20:49:23] AUDIO -> Opening default device
[Oct 12 20:49:23] AUDIO -> OpenAL version: 1.1 ALSOFT 1.15.1
[Oct 12 20:49:23] AUDIO -> Vorbis version: Xiph.Org libVorbis 1.3.3
[Oct 12 20:49:23] FONT -> Initializing font manager…
[Oct 12 20:49:23] FONT -> Freetype version: 2.5.0
[Oct 12 20:49:23] VIDEO -> Initializing video manager…
[Oct 12 20:49:23] VIDEO -> Theora version: Xiph.Org libtheora 1.1 20090822 (Thusnelda)
[Oct 12 20:49:23] CONTROLLER -> System ready!
[Oct 12 20:49:42] CONTROLLER -> I’m afraid, Dave

Hehe, that message at the end occurs when the engine shuts down and is random :slight_smile:

OK, I didn’t test this with a touchpad. It’s very strange. Try the following on dagon.cfg:

controlMode = 2

Which will disable direct control. Also, while in the game, press F3 until you see the CAMERA SLOW message. Let me know how this works!

Sent from my iPhone using Tapatalk - now Free

Hi Agustín,

Thanks so much for taking the time to get back to me, it is much appreciated. :slight_smile:

The controlMode=2 worked, I did not have to change the camera speed!

Now I can play the game, I see there appears to be an issue with it running in full screen. It seems that only the top left hand corner is visible. See splash.png for details.

When I run the game in windowed mode, I can see all the screen, however the taskbar appears at the bottom of the screen and intrudes when I try to move the mouse down towards the bottom (see windowed.png), besides this I’d really rather play the game in full screen.

I have tried full screen in multiple resolutions from 1920 x 1080 down to 1024 by 768, along with changing the config file, but they all exhibit the same behaviour - do you have any suggestions?

I am running the latest Intel HD 4000 drivers.

Finally, one last thing. When I move in the game, for example when you start off in the cafeteria and you move towards the doors that are blocked by something the screen seems to show a ghost image of your current position which gradually fades as you move towards the destination. See the doors and tables on moving.png for an example - apologies if I have not explained this very well, let me know if not and I will try to take a video capture.

The crash on the original dagon version was due to my graphics driver being too new ???, if I rolled back the graphics driver then I could play both versions without crashing - just thought I’d let you know.

Sorry for all the questions, I really want to get the best performance possible as I cannot wait to play this game.


OK, the “ghost fade” is actually intended. It’s supposed to make you feel as if you are walking. Is it too slow? Roughly, how many seconds would you say it’s taking? Because it should be around 1-2 seconds.

As for fullscreen, did you try the new engine with the default settings? That is, displayWidth/Height were commented. I assume that you did, but better be safe :slight_smile:

Also, this is Windows, right?? You seem to be running some window decoration. Could you try disabling that?

Hi Agustín,

Problem solved! :slight_smile:

You may remember I am using a Microsoft Surface Pro, by default this has a display setting (within Control Panel) of 150%, I thought this only affected the size of desktop items, however it also appears to do something with applications too - I am not sure if this is by design or not.

I simply set the scaling to 100% and everything works perfectly. The teaser looks awesome at 1080p!

With regards to the ghost fading, it does only last 1-2 seconds, but I find it a bit distracting - will there be an option to disable this? Not a problem - just curious.

I cannot wait for this game so I went and purchased Scratches Directors Cut on the strength of the Asylum Teaser. Just about to start playing it now, in fact this is what helped me resolve the resolution issue as it exhibited the same issues as the teaser.

Thanks again for your prompt responses - much appreciated!

Ah, there you go, annoying Microsoft again :stuck_out_tongue:

Seriously, glad to hear it’s worked out. As for the transitions, I don’t have plans to allow disabling them, but they will be faster in the actual game. Hope you enjoy Scratches! :slight_smile:

I know this is off topic but it is an issue. Is the game supposed to lag while opening doors? Because mine does, but for every other place in the teaser it doesn’t lag. So only when I open doors that it lags.

When you say “lag”, you mean it takes long to load the next room? For example, when the door stops opening, is that the moment the game pauses?

Just completed it - great fun, with some serious brain teasers in there! Reg Llama eh, I know him well! :wink:

About to tackle the last visit!